转载

pip install imgaug安装失败解决办法

(tensorflow-gpu) E:\学习\深度学习\Mask_RCNN-master>pip install imgaug
Collecting imgaug
  Using cached https://files.pythonhosted.org/packages/17/a9/36de8c0e1ffb2d86f871cac60e5caa910cbbdb5f4741df5ef856c47f4445/imgaug-0.2.9-py2.py3-none-any.whl
Requirement already satisfied: numpy>=1.15.0 in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.16.3)
Collecting Pillow (from imgaug)
  Using cached https://files.pythonhosted.org/packages/e6/37/fc5bde88462cf8a069e522dd6a0d259b69faba1326f0a3ce8b4e11d9f317/Pillow-6.0.0-cp36-cp36m-win_amd64.whl
Requirement already satisfied: opencv-python in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (3.4.1.15)
Requirement already satisfied: six in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.12.0)
Collecting scikit-image>=0.11.0 (from imgaug)
  Using cached https://files.pythonhosted.org/packages/24/d5/a016b686ba4030c7e6039033bef899ff8a790819479016b2365eb929eacc/scikit_image-0.15.0-cp36-none-win_amd64.whl
Requirement already satisfied: scipy in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.2.1)
Collecting Shapely (from imgaug)
  Using cached https://files.pythonhosted.org/packages/a2/fb/7a7af9ef7a35d16fa23b127abee272cfc483ca89029b73e92e93cdf36e6b/Shapely-1.6.4.post2.tar.gz
    ERROR: Complete output from command python setup.py egg_info:
    ERROR: Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:\Users\ADMINI~1\AppData\Local\Temp\pip-install-zkw2801x\Shapely\setup.py", line 80, in <module>
        from shapely._buildcfg import geos_version_string, geos_version, \
      File "C:\Users\ADMINI~1\AppData\Local\Temp\pip-install-zkw2801x\Shapely\shapely\_buildcfg.py", line 200, in <module>
        lgeos = CDLL("geos_c.dll")
      File "d:\program files\anaconda3\envs\tensorflow-gpu\lib\ctypes\__init__.py", line 348, in __init__
        self._handle = _dlopen(self._name, mode)
    OSError: [WinError 126] 找不到指定的模块。
    ----------------------------------------
ERROR: Command "python setup.py egg_info" failed with error code 1 in C:\Users\ADMINI~1\AppData\Local\Temp\pip-install-zkw2801x\Shapely\

1.登录https://www.lfd.uci.edu/~gohlke/pythonlibs/#shapely 下载相对应的版本;

2.通过以下命令进行安装:

(tensorflow-gpu) E:\学习\深度学习\Mask_RCNN-master>python -m pip install Shapely-1.6.4.post1-cp36-cp36m-win_amd64.whl
Processing e:\学习\深度学习\mask_rcnn-master\shapely-1.6.4.post1-cp36-cp36m-win_amd64.whl
Installing collected packages: Shapely
Successfully installed Shapely-1.6.4.post1

3.再通过pip install imgaug进行安装,则成功:

(tensorflow-gpu) E:\学习\深度学习\Mask_RCNN-master>pip install imgaug
Collecting imgaug
  Using cached https://files.pythonhosted.org/packages/17/a9/36de8c0e1ffb2d86f871cac60e5caa910cbbdb5f4741df5ef856c47f4445/imgaug-0.2.9-py2.py3-none-any.whl
Collecting scikit-image>=0.11.0 (from imgaug)
  Using cached https://files.pythonhosted.org/packages/24/d5/a016b686ba4030c7e6039033bef899ff8a790819479016b2365eb929eacc/scikit_image-0.15.0-cp36-none-win_amd64.whl
Collecting Pillow (from imgaug)
  Using cached https://files.pythonhosted.org/packages/e6/37/fc5bde88462cf8a069e522dd6a0d259b69faba1326f0a3ce8b4e11d9f317/Pillow-6.0.0-cp36-cp36m-win_amd64.whl
Requirement already satisfied: opencv-python in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (3.4.1.15)
Requirement already satisfied: Shapely in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.6.4.post1)
Requirement already satisfied: numpy>=1.15.0 in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.16.3)
Requirement already satisfied: six in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.12.0)
Collecting imageio (from imgaug)
  Using cached https://files.pythonhosted.org/packages/af/0a/943c965d372dae0b1f1482677d29030ab834351a61a9a632fd62f27f1523/imageio-2.5.0-py3-none-any.whl
Collecting matplotlib (from imgaug)
  Using cached https://files.pythonhosted.org/packages/21/4c/35fa1837a705f33621604a1967b1505bd3f695940fdf02fad77ef11de196/matplotlib-3.0.3-cp36-cp36m-win_amd64.whl
Requirement already satisfied: scipy in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from imgaug) (1.2.1)
Collecting PyWavelets>=0.4.0 (from scikit-image>=0.11.0->imgaug)
  Using cached https://files.pythonhosted.org/packages/d9/98/2e0af756fa7c1bb49f752078c3e5c1dbf0d98b800c0a9c6f37d7a5cef2ef/PyWavelets-1.0.3-cp36-none-win_amd64.whl
Collecting networkx>=2.0 (from scikit-image>=0.11.0->imgaug)
  Using cached https://files.pythonhosted.org/packages/85/08/f20aef11d4c343b557e5de6b9548761811eb16e438cee3d32b1c66c8566b/networkx-2.3.zip
Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from matplotlib->imgaug) (2.4.0)
Collecting kiwisolver>=1.0.1 (from matplotlib->imgaug)
  Using cached https://files.pythonhosted.org/packages/64/46/75ab48386cbd56065f5542360562be524ad599911455b6d95520cb118613/kiwisolver-1.1.0-cp36-none-win_amd64.whl
Collecting cycler>=0.10 (from matplotlib->imgaug)
  Using cached https://files.pythonhosted.org/packages/f7/d2/e07d3ebb2bd7af696440ce7e754c59dd546ffe1bbe732c8ab68b9c834e61/cycler-0.10.0-py2.py3-none-any.whl
Requirement already satisfied: python-dateutil>=2.1 in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from matplotlib->imgaug) (2.8.0)
Requirement already satisfied: decorator>=4.3.0 in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from networkx>=2.0->scikit-image>=0.11.0->imgaug) (4.4.0)
Requirement already satisfied: setuptools in d:\program files\anaconda3\envs\tensorflow-gpu\lib\site-packages (from kiwisolver>=1.0.1->matplotlib->imgaug) (41.0.1)
Building wheels for collected packages: networkx
  Building wheel for networkx (setup.py) ... done
  Stored in directory: C:\Users\Administrator\AppData\Local\pip\Cache\wheels\de\63\64\3699be2a9d0ccdb37c7f16329acf3863fd76eda58c39c737af
Successfully built networkx
Installing collected packages: PyWavelets, Pillow, imageio, networkx, scikit-image, kiwisolver, cycler, matplotlib, imgaug
Successfully installed Pillow-6.0.0 PyWavelets-1.0.3 cycler-0.10.0 imageio-2.5.0 imgaug-0.2.9 kiwisolver-1.1.0 matplotlib-3.0.3 networkx-2.3 scikit-image-0.15.0

 

转载于:https://www.cnblogs.com/freedomtrail/p/10825268.html

正文到此结束
本文目录